264 - Count on Cantor
UVa網站題目連結
My Solved Problems Performance
My Solved Problems Performance
One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.
In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.
Input and Output
You are to write a program that will read a list of numbers in the range from 1 to and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.
The input list contains a single number per line and will be terminated by end-of-file.
Sample input
3
14
7
Sample output
TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4
Solution
關鍵字:UVa Online Judge, ACM. Java
- import java.io.BufferedInputStream;
- import java.util.Scanner;
- public class Main {
- public static void main(String args[]) {
- int n, loopCounter, sum;
- Scanner in = new Scanner(new BufferedInputStream(System.in));
- while (in.hasNext()) {
- n = in.nextInt();
- for (loopCounter=1, sum = 0;(sum+=loopCounter)<n;loopCounter++) {}
- if ((loopCounter&1)==1)
- System.out.println("TERM " + n + " IS " +(1+(sum-n))+"/" + (
- loopCounter-(sum-n)));
- else
- System.out.println("TERM " + n + " IS " + (loopCounter-(sum-n))+
- "/" +(1+(sum-n)));
- }
- }
- }
留言
張貼留言