113 - Power of Cryptography
My Solved Problems Performance
Background
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
The Problem
Given an integer and an integer you are to write a program that determines , the positive root of p. In this problem, given such integers n and p, p will always be of the form for an integer k (this integer is what your program must find).
The Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs , and there exists an integer k, such that .
The Output
For each integer pair n and p the value should be printed, i.e., the number k such that .
Sample Input
2
16
3
27
7
4357186184021382204544
Sample Output
4
3
1234
Solution
關鍵字:UVa Online Judge, ACM. Java
- import java.io.BufferedInputStream;
- import java.util.Scanner;
- public class Main {
- public static void main(String args[]) {
- double n, p;
- int k;
- Scanner in = new Scanner(new BufferedInputStream(System.in));
- while (in.hasNext()) {
- n = in.nextDouble();
- p = in.nextDouble();
- k = (int) Math.round(Math.pow(p, (double)1/n));
- System.out.println(k);
- }
- }
- }
留言
張貼留言