10929 - You can say 11
UVa網站題目連結
My Solved Problems Performance
Introduction to the problem
Your job is, given a positive number N, determine if it is a multiple of eleven.
Description of the input
The input is a file such that each line contains a positive number. A line containing the number 0 is the end of the input. The given numbers can contain up to 1000 digits.
Description of the output
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.
Sample input:
112233
30800
2937
323455693
5038297
112234
0
Sample output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.
Solution
My Solved Problems Performance
Introduction to the problem
Your job is, given a positive number N, determine if it is a multiple of eleven.
Description of the input
The input is a file such that each line contains a positive number. A line containing the number 0 is the end of the input. The given numbers can contain up to 1000 digits.
Description of the output
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.
Sample input:
112233
30800
2937
323455693
5038297
112234
0
Sample output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.
Solution
關鍵字:UVa Online Judge, ACM. Java
- import java.io.BufferedInputStream;
- import java.math.BigInteger;
- import java.util.Scanner;
- public class Main {
- public static void main(String[] args) {
- Scanner in = new Scanner(new BufferedInputStream(System.in));
- BigInteger bigInt;
- String s;
- while (!(s=in.nextLine().trim()).equals("0")) {
- System.out.print(s);
- while (s.charAt(0)=='0') s = s.substring(1);
- bigInt = new BigInteger(s);
- if (bigInt.divideAndRemainder(new BigInteger(String.valueOf(11)))[1].
- equals(BigInteger.ZERO))
- System.out.println(" is a multiple of 11.");
- else
- System.out.println(" is not a multiple of 11.");
- }
- }
- }
留言
張貼留言