326 - Extrapolation Using a Difference Table
My Solved Problems Performance
A very old technique for extrapolating a sequence of values is based on the use of a difference table. The difference table used in the extrapolation of a sequence of 4 values, say 3, 6, 10, and 15, might be displayed as follows:
The original sequence of values appears in the first column of the table. Each entry in the second column of the table is formed by computing the difference between the adjacent entries in the first column. These values (in the second column) are called first differences. Each entry in the third column is similarly the difference between the adjacent entries in the second column; the third column entries are naturally called second differences. Computation of the last column in this example should now be obvious (but beware that this value is not always zero). Note that the last column will always contain only a single value. If we begin with a sequence of n values, the completed difference table will have n columns, with the single value in column n representing the single n-1st difference.
To extrapolate using a difference table we assume the n-1st differences are constant (since we have no additional information to refute that assumption). Given that assumption, we can compute the next entry in the n-2nd difference column, the n-3rd difference column, and so forth until we compute the next entry in the first column which, of course, is the next value in the sequence. The table below shows the four additional entries (in boxes) added to the table to compute the next entry in the example sequence, which in this case is 21. We could obviously continue this extraolation process as far as desired by adding additional entries to the columns using the assumption that the n-1st differences are constant.
Input and Output
The input for this problem will be a set of extraolation requests. For each request the input will contain first an integer n, which specifies the number of values in the sequence to be extended. When n is zero your program should terminate. If n is non-zero (it will never be larger than 10), it will be followed by n integers representing the given elements in the sequence. The last item in the input for each extrapolation request is k, the number of extrapolation operations to perform; it will always be at least 1. In effect, you are to add k entries to each column of the difference table, finally reporting the last value of the sequence computed by such extrapolation. More precisely, assume the first n entries (the given values) in the sequence are numbered 1 through n.
Your program is to determine the n+kth value in the sequence by extrapolation of the original sequence k times.
Hint: no upper limit is given for k, and you might not be able to acquire enough memory to construct a complete difference table.
Sample Input
4 3 6 10 15 1
4 3 6 10 15 2
3 2 4 6 20
6 3 9 12 5 18 -4 10
0
Sample Output
Term 5 of the sequence is 21
Term 6 of the sequence is 28
Term 23 of the sequence is 46
Term 16 of the sequence is -319268
Solution
關鍵字:UVa Online Judge, ACM. Java
- import java.io.BufferedInputStream;
- import java.util.Scanner;
- import java.util.Vector;
- public class Main {
- static Scanner in = new Scanner(new BufferedInputStream(System.in));
- static int n, k;
- static Vector<Vector<Integer>> int2DArray = new Vector<Vector<Integer>>();
- public static void main(String[] args) {
- while ((n=in.nextInt())!=0) {
- int2DArray = new Vector<Vector<Integer>>();
- for (int i=0; i<n; i++) {
- int2DArray.add(new Vector<Integer>());
- }
- for (int i=0; i<n; i++) {
- int2DArray.elementAt(0).add(i, in.nextInt());
- }
- k = in.nextInt();
- for (int i=1; i<n; i++) {
- for (int j=0; j<n-i; j++) {
- int2DArray.elementAt(i).add(j, int2DArray.elementAt(i-1).
- elementAt(j+1)-int2DArray.elementAt(i-1)
- .elementAt(j));
- }
- }
- for (int i=0; i<k; i++) {
- for (int j=n-1; j>=0; j--) {
- if (j!=n-1) {
- int2DArray.elementAt(j).add(int2DArray.elementAt(j).
- lastElement()+int2DArray.elementAt(
- j+1).lastElement());
- } else {
- int2DArray.elementAt(j).add(int2DArray.elementAt(j).
- lastElement());
- }
- }
- }
- System.out.println("Term " + (n+k) + " of the sequence is " +
- int2DArray.elementAt(0).lastElement());
- }
- }
- }
留言
張貼留言